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LI�ÌO 2: CONCEITOS BçSICOS DE ANIMA�ÌO

OBJETIVOS

Nesta lição, você aprenderá a:

•animar seu desenho
• trabalhar com símbolos e a biblioteca
• trabalhar com camadas, cenas, a linha de tempo e o controlador
• compreender técnicas de animação, como quadros-chave, recurso onion skinning,

modo tweening e animação quadro a quadro

CONTEXTO

Na lição anterior, você criou um desenho simples com um plano de fundo (sol e grama), um

personagem (uma formiga) e algum texto. Nesta seção, você aprenderá as técnicas básicas de

animação de desenhos no Flash. Ao final desta lição, você terá feito os raios de sol brilharem, a

formiga correr pela grama e o texto mudar de tamanho e girar.

EXERCêCIOS

Preparando Seu Desenho para a Animação

Antes de começar a acrescentar animação ao desenho, existem alguns procedimentos que
devem ser tomados para tornar o processo de animação mais fácil e bem organizado. Nesta
seção, você aprenderá a transformar um desenho em um símbolo e adicioná-lo à Biblioteca
(Library) para criar uma nova cena do filme, e para separar as diferentes partes da animação em
camadas.

Transforme a Formiga em um Símbolo da Biblioteca

Um símbolo é um elemento catalogado em uma Biblioteca de
um filme do Flash. Pode ser usado várias vezes em seu filme
sem aumentar o tamanho do arquivo, pois permanece sempre
vinculado ao símbolo original. Conforme você verá na Lição 5,
transformar os personagens em símbolos permite fazer
mudanças globais no personagem, editando-o apenas uma vez
na Biblioteca.

1. Se seu arquivo ant.fla ainda não estiver aberto, abra-o
agora.

2. Selecione a formiga clicando nela com a ferramenta Arrow.
A formiga já deverá ser um elemento agrupado.

3. Escolha Insert > Create Symbol. A caixa de diálogo Symbol
Properties aparecerá.

4. No campo Name, digite “Ant.”
5. Selecione Graphic na opção Behavior. Clique em OK para

terminar.
6. Abra a biblioteca escolhendo Window > Library. Observe a

referência ao seu novo símbolo de formiga (Figura 2-1).

Figura 2-1
O desenho da formiga foi
adicionado à Biblioteca.
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Crie uma Nova Cena

Pense em uma cena do Flash como uma cena de filme. Cenas diferentes ocorrem em diferentes locais
ou em diferentes momentos e podem ter diferentes grupos de personagens. As cenas do Flash facilitam
a organização de diferentes seqüências de sua animação. Enquanto a animação que estiver construindo
for simples, você adotará os procedimentos de criação de uma nova cena e aprenderá como fazer isso.
Basicamente, você criará uma segunda cena no filme, contendo a animação interativa que irá construir.

1. Escolha Insert > Scene. Uma nova guia de cena aparecerá na parte superior direita da janela, junto à
linha de tempo (Figura 2-2). Você pode usar essas guias para alternar entre as diferentes cenas de
seu filme.

2. Clique duas vezes na guia denominada “Scene 2”. Isso irá abrir a caixa de diálogo Scene Properties.
3. Nomeie a cena como “Animation” e, em seguida, clique em OK. Observe que a guia da cena 2 está

agora identificada como “Animation”.

Figura 2-2
Uma nova guia de cena aparece à direita da linha de tempo.

Organize o Desenho em Camadas

A animação que você está construindo terá os seguintes elementos: a formiga se moverá pela tela, o sol

emitirá raios e o texto mudará de tamanho. Cada um dos movimentos separados deve ocorrer em uma

camada separada da linha de tempo de sua cena.

1. Clique na guia Scene 1 para retornar ao desenho original.
2. Usando a ferramenta Arrow, clique para selecionar a linha da grama. (Certifique-se de que a formiga

não esteja selecionada.) Escolha Edit > Copy.
3. Clique na guia de cena Animation para alternar cenas. O Stage deve estar em branco.
4. Escolha Edit > Paste in Place. Isso irá colar a grama exatamente na mesma posição
5. A área de camadas do lado esquerdo da linha de tempo (Figura 2-3) lista a única camada contida na

cena atual. Clique duas vezes nas palavras Layer 1 até que o texto fique destacado, permitindo a
inserção de um novo nome para esta camada. Digite “Grass”. Pressione a tecla Enter ou Return no
teclado para finalizar.

6. Agora, faça uma segunda camada para o sol. Escolha Insert > Layer. Clique duas vezes no nome da
camada e renomeie-a como “Sun”. Pressione Enter ou Return.

Figura 2-3
A área de camadas está localizada à esquerda da linha de tempo.

7. Retorne ao desenho original, clicando na guia Scene 1. Usando a ferramenta Arrow ou Lasso,
selecione todas as partes do desenho do sol. Escolha Edit > Copy. Clique na guia Animation para
retornar à cena Animation.



8. Antes de colar o sol na cena, certifique-se de que a camada Sun é a camada atual. Como saber? A
camada atual terá um pequeno lápis no lado direito do nome. Se o lápis não estiver aparecendo,
basta clicar na camada Sun para torná-la atual.

9. Escolha Edit > Paste in Place para colar o sol em sua própria camada.
10. Finalmente, repita o processo para o texto. Crie uma nova camada, chame-a de “Text” (não se

esqueça de pressionar Enter!), copie o texto da Scene 1 e cole-o na camada Text na cena
Animation.

Agora, você deve  ter uma nova cena chamada “Animation” no filme do Flash. A lista das camadas deve
ficar parecida com a da Figura 2-4. O Stage deve conter a grama, o sol e algum texto (colocaremos a
formiga em cena um pouco mais tarde). Quando estiver preparado, vá em frente e salve seu trabalho.

Figura 2-4
Agora você deve possuir três camadas diferentes em sua cena.

Aprenda Mais sobre as Camadas

Você acabou de aprender a criar uma nova camada e a nomeá-la. Antes de continuar, deve aprender um
pouco mais sobre as camadas da linha de tempo. Consulte a Figura 2-4 enquanto pratica estes exercícios.

1. Observe o círculo branco no lado esquerdo da camada Text, que indica a presença de um objeto
selecionado nessa camada.

2. Clique na imagem da grama no Stage para selecioná-la. Um outro círculo negro deve aparecer
próximo à camada Grass.

3. Os ícones à direita do nome de cada camada são importantes. Cada camada possui seu próprio
Ícone de Camada, indicando o status dessa camada. O ícone do lápis indica qual camada é a atual
ou current; desenhar e colar geralmente afeta a camada atual. O ícone da mão indica uma camada
normal; é possível selecionar, editar e mover itens em uma camada normal.

4. Clique no ícone de camada próximo à camada Sun. O menu pop-up Layer aparece. Esse menu
fornece várias opções de controle e manipulação de camadas. No menu pop-up Layer, selecione
Hidden. O sol deverá desaparecer do Stage e o ícone da camada Sun deverá se transformar em um
olho com um X vermelho.

5. Mais uma vez, clique no ícone da camada Sun. No menu pop-up Layer, selecione Current. O
desenho do sol deve reaparecer.

6. As camadas também podem ser usadas para controlar a sobreposição de objetos. Para ilustrar isso,
use a ferramenta Arrow para selecionar o texto “Where’s the Picnic?” no Stage. Mova o texto para
que ele se sobreponha ao desenho do sol.

7. Na área Layers, selecione a camada Text e arraste-a para baixo. Uma linha de inserção aparecerá
enquanto você arrasta a camada. Quando a linha de inserção estiver entre as camadas Sun e Grass,
solte a camada. Essa ação irá mover a camada Text para baixo da camada Sun. Olhe para o Stage e
observe que o texto está coberto pelo sol.

8. Escolha Edit > Undo para restaurar a ordem original das camadas. Escolha Edit > Undo novamente
para retornar o texto à sua posição original. Felizmente, o Flash permite muitos níveis de Desfazer
Ações (Undo). O número de níveis pode ser alterado na caixa de diálogo File > Preferences.
Quanto mais níveis de Desfazer Ações você especificar (o máximo é 200), mais memória o Flash irá
necessitar.
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COMPREENDENDO AS TÉCNICAS DE ANIMAÇÃO

Antes de começar a animar seu desenho, vamos rever alguns conceitos básicos de animação para que

você entenda as diferentes ferramentas fornecidas pelo Flash.

A essência da animação é uma ilusão de óptica. É feita uma sucessão de desenhos, com pequenas

alterações entre eles. Quando esses desenhos são mostrados em sucessão rápida, a mente humana

automaticamente percebe movimento. Uma forma bem simples de animação é um flip-book, com um

desenho em cada página. Quando você vira as páginas de um livro rapidamente, ocorre o efeito de

movimento. Isso é uma animação.

Cada um dos desenhos individuais em uma animação é chamado de quadro. A linha de tempo no Flash

indica a seqüência de quadros na animação.

Os quadros-chave (ou keyframes) são elementos importantes na criação das animações do Flash.

Imagine uma única seqüência de animação como uma pequena ida de sua casa ao mercado. Para

informar o caminho, você provavelmente mencionaria os cruzamentos importantes. Você diria: “Vá até o

primeiro semáforo e vire à direita. Em seguida, quando você chegar à Rua dos Franceses, pegue a

esquerda”, e assim por diante. Imagine os quadros-chave como cruzamentos ou pontos de mudança de

direção da seqüência de sua animação.

Os dois estilos de animação envolvem diferentes usos dos quadros-chave. No primeiro tipo de

animação, denominado animação quadro a quadro, cada quadro individual é um quadro-chave. Este

método é geralmente  trabalhoso, mas permite um controle preciso sobre a animação. O segundo tipo

de animação é mais parecido com as instruções de um caminho, como descrevemos acima. Esse

método, denominado tweening, usa um quadro-chave inicial e um final e confia ao Flash a criação dos

quadros intermediários (é por causa desses quadros intermediários, em inglês “in-betweening”, que o

processo é chamado de “tweening”). Este segundo método é mais rápido e requer menos memória.

Para uma ilustração do modo tweening, consulte a Figura 2-5.

Figura 2-5
Nesta animação em modo tweening de uma bola pulando, a fileira 
superior apresenta os diferentes quadros e quadros-chave da  animação. 
A fileira intermediária mostra como deverá ser a aparência da animação. 
Um quadro-chave foi feito nos pontos em que a bola muda de direção. 
As linhas pontilhadas mostram os quadros que seriam criados pelo modo 
tweening. A última fileira mostra como um segmento da animação ficaria 
na linha de tempo do Flash.



Nas técnicas de animação tradicionais, a animação era desenhada sobre folhas transparentes de

acetato de celulose. Essas folhas eram colocadas umas sobre as outras (uma técnica denominada onion
skinning). Cada quadro era desenhado como uma referência ao quadro anterior. Esses quadros

desenhados eram então pintados e filmados para criar a seqüência de animação final.

CRIANDO ANIMAÇÕES

Você iniciará criando uma seqüência quadro a quadro com seu desenho do sol. O objetivo é fazer com

que os raios do sol pareçam estar vibrando.

Criando uma Animação Quadro a Quadro

1. Clique na camada Sun para torná-la a atual (procure o lápis no ícone da camada).
2. Cada camada de sua animação possui uma fileira correspondente na linha de tempo. Você deverá

ver um círculo azul no primeiro quadro da linha de tempo da camada Sun. Esse círculo está no
primeiro quadro de sua animação. Clique no círculo e arraste-o até o quadro 20 na linha de tempo.
(Os números dos quadros são exibidos ao longo da parte superior da linha de tempo.) Os primeiros
20 quadros devem estar destacados agora.

3. Escolha Insert > Keyframe. O Flash irá inserir um quadro-chave em cada um dos primeiros 20 quadros.
4. Na linha de tempo, tente clicar em alguns dos quadros que você acabou de criar. O círculo azul

fechado nos quadros da linha de tempo indica que existe uma imagem em cada um dos quadros-
chave. Você perceberá que o Flash copiou o sol dentro de cada quadro. À medida que você se
move de quadro em quadro, observe que a pequena seta apontando para baixo na parte superior da
linha de tempo se movimenta, dependendo do quadro clicado. Essa seta é o ponteiro do quadro e
você poderá arrastá-la para alterar os quadros.

5. Agora, você iniciará o repetitivo processo de animação do sol quadro a quadro. Na linha de tempo,
clique no segundo quadro na camada Sun.

6. O Stage agora exibe o conteúdo do segundo quadro de sua animação. O desenho do sol deve estar
destacado. Pressione a tecla Shift enquanto clica no corpo do sol para desmarcá-lo. Somente os
raios do sol devem estar selecionados agora.

7. Exclua os raios solares usando as teclas Backspace ou Delete
8. Clique no terceiro quadro. Você vai perceber que os raios ainda estão lá. Deixe o quadro como está.
9. Clique no quarto quadro. Repita os procedimentos 5 e 6 para excluir os raios solares.
10. Repita esse processo para todos os quadros da animação.

Execute Sua Animação

1. Escolha Control > Loop Playback.
2. Escolha Window > Controller. O controlador aparecerá, com botões para controlar a execução de

seu filme.
3. Pressione o botão Play (a seta à direita simples) no controlador.
4. Para interromper a execução, pressione o botão quadrado Stop no controlador.
Parabéns! Você acabou de completar sua primeira animação. Agora, vamos prosseguir com algumas
técnicas de animação mais sofisticadas. Nos próximos exercícios, você irá animar a formiga usando o
recurso weening.

Coloque um Símbolo da Biblioteca

É hora de colocar o personagem formiga de volta no filme.

1. Crie uma nova camada e chame-a de “Ant”. (Se precisar de uma relembrada sobre como fazer isso,
consulte a seção anterior sobre a organização de seu desenho em camadas.)

2. Se existirem muitas camadas para exibir na linha de tempo, você poderá arrastar o divisor da tela
abaixo da linha de tempo para obter mais espaço.

3. Escolha Window > Library. A Biblioteca irá aparecer.
4. Certifique-se de que a camada Ant é a atual. Observe que o primeiro quadro da linha de tempo da

camada Ant possui um círculo azul aberto. Isso indica um quadro-chave vazio (lembre-se de que um
círculo azul fechado indica um quadro-chave com uma imagem dentro).
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5. Clique no primeiro quadro na linha de tempo da camada Ant
6. Clique no desenho da formiga na Biblioteca e arraste-o para o Stage. Isso colocará o símbolo da

formiga em sua animação.
7. Feche a Biblioteca.

O próximo passo é animar a formiga com o recurso tweening. Lembre-se de que você terá de usar um
grupo ou um símbolo para animações em modo tweening. Por isso, poderá animar a formiga em modo
tweening, mas não o sol, porque ele não está agrupado.

Crie uma Animação Usando o Modo Tweening

Agora, você fará a formiga correr pela tela da esquerda para a direita. 

1. Usando a ferramenta Arrow, mova a formiga para a extremidade esquerda do Stage.
2. Na linha de tempo da Formiga, clique no quadro 20.
3. Escolha Insert > Keyframe. Observe como o Flash copia a imagem da formiga do quadro-chave

anterior nessa camada (neste caso, quadro 1).
4. Mova a imagem da formiga para a extrema direita do Stage.
5. Clique novamente no primeiro quadro da linha de tempo da Formiga. Isso fará a formiga aparecer do

lado esquerdo da tela.
6. Dê um clique duplo nesse quadro na linha de tempo. Isso abrirá a caixa de diálogo Frame Properties.
7. Selecione a guia Tweening. Use o menu pop-up para selecionar Motion no menu pop-up Tweening.

Deixe as outras opções em seu estado padrão e clique em OK para terminar.
8. Observe que a linha de tempo mudou. A camada Ant possui uma linha vermelha com uma seta entre

os dois quadros-chave, indicando que nos quadros intermediários foi aplicado o modo tweening. O
primeiro quadro-chave, agora, possui um círculo vermelho em vez de um azul; o vermelho indica um
quadro-chave em modo tweening.

9. Usando o controlador, pressione Play para visualizar sua animação. A formiga deve caminhar pela
tela e os raios solares devem vibrar.

10. Se estiver satisfeito com sua animação até agora, escolha File > Save para salvar seu trabalho.

Crie uma Imagem de Fundo Fixa

A formiga parece viva e o sol quente, mas é meio estranho que a grama desapareça logo após o primeiro
quadro. Neste exercício, você estenderá a imagem da grama por toda a animação. Já que você não quer
que o chão se movimente ou se altere, não precisará de um outro quadro-chave para esta camada.

1. Na camada Grass da linha de tempo, clique no quadro 20.
2. Escolha Insert > Frame. Isso irá copiar a imagem da grama em cada quadro da animação.
3. Usando o controlador, visualize sua animação.

Use o recurso Onion Skinning

A última animação que você fará será com a camada Text. Neste exercício, você usará o recurso onion
skinning para ajudar a criar os procedimentos em sua animação. Você também estará combinando várias
das técnicas usadas até agora para criar uma seqüência de animação mais complexa.

O recurso onion skinning é o processo que permite visualizar o quadro anterior como se ele estivesse
sobre uma película de casca de cebola. Esta técnica originou-se dos animadores tradicionais que
usavam a pele da cebola para ver os desenhos subjacentes, copiando algumas partes deles e alterando
outras para dar a impressão de que algumas delas estariam fixas e outras se movendo.

1. Clique na camada Text para torná-la atual. Certifique-se de que nenhuma imagem esteja selecionada
nesta cena.

2. Clique no quadro 5 da linha de tempo Text. Para fazer o menu pop-up Frame aparecer, clique com
o botão direito do mouse (PC) ou clique no quadro 5 e o mantenha pressionado (Mac). O menu
pop-up Frame fornece algumas das funções do menu Insert, mas é uma forma mais rápida de
acessar comandos de controle de quadros.

3. No menu pop-up Frame, selecione Insert Keyframe.
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4. Localize o botão Onion Skin. Na Figura 2-6, é o botão na parte superior esquerda, logo acima dos
nomes das camadas. Clique nele para acionar o recurso onion skinning. Você pode perceber, agora,
imagens transparentes do movimento da formiga.

Figura 2-6
O botão onion skinning encontra-se na parte superior 
esquerda, logo acima da camada Ant.

5. Observe que dois novos marcadores aparecem no topo da linha de tempo. Eles determinam quantos
quadros são exibidos por meio do recurso onion skinning. Deslize o marcador Onion Skin esquerdo
para trás até o primeiro quadro para mostrar a posição inicial do texto.

6. O quadro 5 ainda deve estar selecionado. Usando a ferramenta Arrow, selecione o texto “Where’s
the Picnic?” e mova-o para baixo e para a direita cerca de dois centímetros.

7. Escolha Modify > Transform > Scale and Rotate. Digite 60 na caixa Scale. Clique em OK para
terminar.

8. Sua tela deverá estar parecida com a da Figura 2-7. Para fazer uma transição gradativa do texto
grande para o pequeno, clique duas vezes no quadro 1 da camada Text. Clique na guia Tweening,
selecione Motion  no menu pop-up Tweening e clique em OK para terminar.

Figura 2-7
Com o onion skinning ativado, é possível ver a escala relativa e a 
posição do texto.

9. Em seguida, você fará com que o texto menor fique girando. Clique no quadro 15 da linha de tempo
Text. Usando o menu pop-up Frame, escolha Insert Keyframe.

10. Clique duas vezes no quadro 5 para fazer surgir a caixa de diálogo Frame Properties. Selecione a
guia Tweening.

11. No menu pop-up Tweening, selecione Motion. Aparecerão mais opções agora na caixa de diálogo.
12. No menu pop-up Rotate, selecione Clockwise. Na caixa à direita, digite “1” para que a rotação em

sentido horário ocorra uma vez.
13. Clique em OK para terminar.
14. Finalmente, você deverá estender um quadro fixo do texto até o final da animação. Clique no quadro

20 da linha de tempo da camada Text. Usando o menu pop-up Frame, selecione Insert Frame. Você
não precisará de um novo quadro-chave aqui, uma vez que nada irá mudar.
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15. Agora, execute sua animação com o controlador. É possível visualizar também a animação em
câmera lenta deslizando o ponteiro do quadro (na parte superior da linha de tempo) vagarosamente
sobre os quadros. Convém primeiro desativar o recurso onion skinning clicando no botão Onion Skin.

16. Este é um bom momento para salvar seu trabalho.

Modifique uma Animação em Modo Tweening

Uma das vantagens do modo tweening é que ele facilita a alteração da animação. Você precisará
apenas modificar os quadro-chave para o Flash alterar os quadros intermediários automaticamente.
Primeiro, você fará a formiga aparecer e desaparecer nas extremidades do Stage.

1. Selecione a camada Ant na linha de tempo. Clique no quadro 1.
2. Usando a ferramenta Arrow, mova a formiga um pouco mais para a esquerda, para que somente a

parte dianteira de seu corpo permaneça no Stage (Figura 2-8).
3. Clique no último quadro (quadro 20) da linha de tempo da camada Ant.
4. Mova a formiga para a direita, para que somente sua parte traseira permaneça no Stage.
5. Execute o filme com o controlador para visualizar suas alterações. Observe que o Flash automati-

camente atualiza os quadros intermediários para refletir as alterações que você fez nos quadros-
chave.

Em seguida, você fará a formiga se mover pelo Stage mais rapidamente, deixando alguns quadros em
que ela não aparece em cena.

1. Mantendo pressionada as teclas Control (Window) ou Command (Macintosh), selecione o último
quadro na linha de tempo da camada Ant. Ainda mantendo pressionada a tecla Control ou
Command, arraste o quadro para a esquerda na direção ao quadro 10 e, em seguida, solte-o. Isso
irá reduzir a seqüência de movimento da formiga em dez quadros.

2. Usando o controlador, execute sua animação. Observe que a ação permanece a mesma, exceto
pelo fato de que parece mais rápida. Observe também que existem agora cerca de 10 quadros nos
quais a formiga não aparece em cena.

3. Salve seu arquivo.

MAIS EXERCÍCIOS PARA ESTIMULAR SUAS HABILIDADES

• Salve uma cópia do seu filme ant.fla como ant2.fla. Use essa nova cópia enquanto estiver
fazendo estes exercícios.

• Tente mudar o movimento da formiga e o texto de diferentes maneiras. Use os controles do
modo Tweening na caixa de diálogo Frame Properties para testar diferentes configurações.

• Acrescente uma nova camada ao seu desenho. Crie mais alguns elementos de plano de fundo.
Pratique a criação de quadros de plano de fundo fixos que se estendem por toda a animação.

• Copie o sol para uma nova camada e tente criar uma animação em modo tweening com ele.
Você descobrirá que não consegue fazer isso até transformar o desenho do sol em um
elemento agrupado. Faça com que o sol se levante e se ponha.

• Experimente movimentar os quadros na linha de tempo usando os comandos Copy, Cut e Paste.
• Tente alterar a extensão de diferentes seqüências de animação.

Figura 2-8
Mova a formiga quase
para fora do Stage.


